summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2008-12-01 09:24:00 +0000
committerAlexander Larsson <alexl@src.gnome.org>2008-12-01 09:24:00 +0000
commitf8875b2649a0f85624e0da7df96fa6d47840c4a9 (patch)
treedf7f32b8849652f03b597aead9f1b56d697d806a /common/Makefile.am
parent6e89574f1656ff71f5aba339ff38e8e0417b172b (diff)
downloadgvfs-f8875b2649a0f85624e0da7df96fa6d47840c4a9.tar.gz
Added. Added. Added. Added.
2008-12-01 Alexander Larsson <alexl@redhat.com> * common/Makefile.am: * common/gvfsdnssdresolver.c: Added. * common/gvfsdnssdresolver.h: Added. * common/gvfsdnssdutils.c: Added. * common/gvfsdnssdutils.h: Added. * daemon/Makefile.am: * daemon/dav+sd.mount.in: Added. * daemon/dav.mount.in: * daemon/gvfsbackenddav.c: * daemon/gvfsbackenddnssd.c: * daemon/gvfsbackendnetwork.c: For references to dns-sd dav services, use a dav+sd: uri, since this is stable over e.g. port changes and as such work better in e.g. bookmarks. Patch from David Zeuthen (#555436) svn path=/trunk/; revision=2112
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 12dd9e83..4e10cf8b 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -22,3 +22,20 @@ libgvfscommon_la_SOURCES = \
libgvfscommon_la_LIBADD = \
$(DBUS_LIBS) \
$(GLIB_LIBS)
+
+if HAVE_AVAHI
+lib_LTLIBRARIES += libgvfscommon-dnssd.la
+
+libgvfscommon_dnssd_la_SOURCES = \
+ gvfsdnssdutils.c gvfsdnssdutils.h \
+ gvfsdnssdresolver.c gvfsdnssdresolver.h \
+ $(NULL)
+
+libgvfscommon_dnssd_la_CFLAGS = \
+ $(AVAHI_CFLAGS)
+
+libgvfscommon_dnssd_la_LIBADD = \
+ $(top_builddir)/common/libgvfscommon.la \
+ $(AVAHI_LIBS)
+endif
+