summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Jon McCann <jmccann@redhat.com>2012-07-10 19:49:59 -0400
committerWilliam Jon McCann <jmccann@redhat.com>2012-07-13 10:09:08 -0400
commit86137e52d78b2a03b90964c090656f4820f77c78 (patch)
treee8bc67bf4263efef47f5007ba8054229c22076ca /configure.ac
parent90e499e06040b5aa4adbefa20ccf78860ed67492 (diff)
downloadgvfs-86137e52d78b2a03b90964c090656f4820f77c78.tar.gz
Enable more warnings with git
https://bugzilla.gnome.org/show_bug.cgi?id=679719
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8f89621b..5052afb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -746,14 +746,13 @@ dnl Turn on the additional warnings last, so -Werror doesn't affect other tests.
AC_ARG_ENABLE(more-warnings,
AS_HELP_STRING([--enable-more-warnings],[Maximum compiler warnings]),
set_more_warnings="$enableval",[
-if test -f $srcdir/CVSVERSION; then
- is_cvs_version=true
+if test -f $srcdir/.git; then
set_more_warnings=yes
else
set_more_warnings=no
fi
])
-AC_MSG_CHECKING(for more warnings, including -Werror)
+AC_MSG_CHECKING(for more warnings)
if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
AC_MSG_RESULT(yes)
CFLAGS="\