summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2009-11-05 21:49:38 +0000
committerBastien Nocera <hadess@hadess.net>2009-11-09 19:04:18 +0000
commitcc467bfa5259c1fdb31a54398cd6a4b6085e1fb2 (patch)
tree745bea765d32e12c4e798bc97e4e08e55da6c709 /configure.ac
parent92c179d6ce2682595e7ce1a77e301ffc49e25526 (diff)
downloadgvfs-cc467bfa5259c1fdb31a54398cd6a4b6085e1fb2.tar.gz
[common] Loading icon and title on Blu-ray video discs
Using the BDMV/META/DL/bdmt_eng.xml file on BDMV discs, we can load better names and icons for the disc. Adds expat requirement to the common library if it is found. https://bugzilla.gnome.org/show_bug.cgi?id=600887
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 16 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index a8b3d612..bb32b63f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,6 +210,22 @@ fi
AM_CONDITIONAL(USE_GCONF, [test "$msg_gconf" = "yes"])
+dnl ********************************************
+dnl *** Check for expat (for obexftp and gdu ***
+dnl ********************************************
+
+dnl Make sure we have expat
+AC_CHECK_LIB(expat, XML_ParserCreate_MM,
+ [ AC_CHECK_HEADERS(expat.h, have_expat=true, have_expat=false) ],
+ have_expat=false)
+if test "x$have_expat" = "xtrue"; then
+ EXPAT_CFLAGS=""
+ EXPAT_LIBS="-lexpat"
+ AC_DEFINE(HAVE_EXPAT,, [Define to 1 if you have expat available])
+fi
+AC_SUBST(EXPAT_CFLAGS)
+AC_SUBST(EXPAT_LIBS)
+
dnl ************************************
dnl *** Check for gnome-disk-utility ***
dnl ************************************
@@ -328,11 +344,6 @@ OBEXFTP_CFLAGS=
if test "x$enable_obexftp" != "xno"; then
PKG_CHECK_EXISTS(dbus-glib-1 bluez >= 4.0, msg_obexftp=yes)
- dnl Make sure we have expat
- AC_CHECK_LIB(expat, XML_ParserCreate_MM,
- [ AC_CHECK_HEADERS(expat.h, have_expat=true, have_expat=false) ],
- have_expat=false)
-
if test "x$msg_obexftp" = "xyes" -a "x$have_expat" = "xtrue"; then
PKG_CHECK_MODULES(OBEXFTP, dbus-glib-1 bluez >= 4.0)
AC_SUBST(OBEXFTP_LIBS)
@@ -340,15 +351,11 @@ if test "x$enable_obexftp" != "xno"; then
msg_obexftp=yes
AC_DEFINE(HAVE_OBEXFTP, 1, [Define to 1 if ObexFTP is going to be built])
- EXPAT_CFLAGS=""
- EXPAT_LIBS="-lexpat"
else
msg_obexftp=no
fi
fi
-AC_SUBST(EXPAT_CFLAGS)
-AC_SUBST(EXPAT_LIBS)
AM_CONDITIONAL(USE_OBEXFTP, [test "$msg_obexftp" = "yes"])
dnl *************************