summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pieuchot <mpi@openbsd.org>2012-07-13 16:51:39 +0200
committerTomas Bzatek <tbzatek@redhat.com>2012-07-13 16:51:39 +0200
commit2fec402d6523e4cf416d754f69d012dc67a58a2e (patch)
tree67b022d0879405b769d993820d3aed61dba7c109 /configure.ac
parente3890ddd806a7e2f89ac17d61a4aac0fa4eb7006 (diff)
downloadgvfs-2fec402d6523e4cf416d754f69d012dc67a58a2e.tar.gz
daemon: Support allocating PTYs through openpty on BSD
Allows systems supporting the BSD openpty(3) utily function but not the Unix98 PTY function family (grantpt(3), unlockpt(3), ...) to allocate a pseudo-tty required for the ssh authentication. https://bugzilla.gnome.org/show_bug.cgi?id=679790 Signed-off-by: Tomas Bzatek <tbzatek@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2f3260c5..c9be6404 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,9 +119,13 @@ AC_CHECK_FUNCS(getpt posix_openpt grantpt unlockpt ptsname ptsname_r)
# Pull in the right libraries for various functions which might not be
# bundled into an exploded libc.
AC_CHECK_FUNC(socketpair,[have_socketpair=1],AC_CHECK_LIB(socket,socketpair,[have_socketpair=1; LIBS="$LIBS -lsocket"]))
+AC_CHECK_FUNC(openpty,[have_openpty=1],AC_CHECK_LIB(util,openpty,[have_openpty=1; LIBS="$LIBS -lutil"]))
if test x$have_socketpair = x1 ; then
AC_DEFINE(HAVE_SOCKETPAIR,1,[Define if you have the socketpair function.])
fi
+if test x$have_openpty = x1 ; then
+ AC_DEFINE(HAVE_OPENPTY,1,[Define if you have the openpty function.])
+fi
AC_SEARCH_LIBS(login_tty, util, [AC_DEFINE([HAVE_LOGIN_TTY],[],[Whether login_tty is available])])