summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDebarshi Ray <debarshir@gnome.org>2012-10-23 21:46:33 +0200
committerDebarshi Ray <debarshir@gnome.org>2013-02-05 17:25:39 +0100
commit267bb33e0e3586f078a0d38ee2ccc5bd1ccab911 (patch)
treeacbae31e7facbdfb3297d76bcc8392877c2fc661 /configure.ac
parent1cffe26596fbc35c0dd63fa3cd26702973e0f08a (diff)
downloadgvfs-267bb33e0e3586f078a0d38ee2ccc5bd1ccab911.tar.gz
Add GVfsGoaVolumeMonitor
https://bugzilla.gnome.org/show_bug.cgi?id=686526
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4848c16e..9373fa14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -388,6 +388,28 @@ AC_SUBST(AFC_CFLAGS)
AM_CONDITIONAL(USE_AFC, [test "$msg_afc" = "yes"])
+dnl *************************************************
+dnl *** Check if we should build with GOA backend ***
+dnl *************************************************
+AC_ARG_ENABLE(goa, AS_HELP_STRING([--disable-goa],[build without GOA backend]))
+msg_goa=no
+GOA_LIBS=
+GOA_CFLAGS=
+
+if test "x$enable_goa" != "xno" ; then
+ PKG_CHECK_EXISTS(goa-1.0 >= 3.7.1, msg_goa=yes)
+
+ if test "x$msg_goa" = "xyes"; then
+ PKG_CHECK_MODULES(GOA, goa-1.0)
+ AC_DEFINE(HAVE_GOA, 1, [Define to 1 if GOA is going to be built])
+ fi
+fi
+
+AC_SUBST(GOA_LIBS)
+AC_SUBST(GOA_CFLAGS)
+
+AM_CONDITIONAL(USE_GOA, [test "$msg_goa" = "yes"])
+
dnl *****************************************************
dnl *** Check if we should build with obexftp backend ***
dnl *****************************************************
@@ -879,6 +901,7 @@ monitor/udisks2/Makefile
monitor/gphoto2/Makefile
monitor/afc/Makefile
monitor/mtp/Makefile
+monitor/goa/Makefile
programs/Makefile
man/Makefile
test/Makefile
@@ -908,6 +931,7 @@ echo "
Build HAL volume monitor: $msg_hal (with fast init path: $have_hal_fast_init)
Build GDU volume monitor: $msg_gdu
Build udisks2 volume monitor: $msg_udisks2
+ Build GOA volume monitor: $msg_goa
Use libsystemd-login: $msg_libsystemd_login
GNOME Keyring support: $msg_keyring
GTK+ support: $msg_gtk