summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomas Bzatek <tbzatek@redhat.com>2013-01-24 15:48:28 +0100
committerTomas Bzatek <tbzatek@redhat.com>2013-01-24 15:48:28 +0100
commitc79426bf1f5745b7e3427958a0e6fb6e0bdefa93 (patch)
tree09e9926cf1d8a75c93cff86aa0fcbf32f87ccf35 /configure.ac
parent2ad82f2751b4a13dbcf8e7373a386019982bb43b (diff)
downloadgvfs-c79426bf1f5745b7e3427958a0e6fb6e0bdefa93.tar.gz
cdda: Adapt to new paranoia.h location
With the 0.90+ release libcdio-paranoia has been split out and headers have moved. Adapt to this change by finding actual header location and ifdef-ing includes in our sources. https://bugzilla.gnome.org/show_bug.cgi?id=691841
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 98f2ebc2..4848c16e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -348,9 +348,19 @@ if test "x$enable_cdda" != "xno" -a \( "x$msg_hal" = "xyes" -o "x$msg_gudev" = "
if test "x$msg_cdda" = "xyes"; then
PKG_CHECK_MODULES(CDDA, libcdio_paranoia)
AC_DEFINE(HAVE_CDDA, 1, [Define to 1 if CDDA is going to be built])
+
+ # test for actual headers location
+ CPPFLAGS_save="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $CDDA_CFLAGS"
+ AC_CHECK_HEADER(cdio/paranoia/paranoia.h, [
+ AC_DEFINE(HAVE_PARANOIA_NEW_INCLUDES, 1, [Define to 1 if cdio/paranoia/paranoia.h is present]) ])
+ CPPFLAGS="$CPPFLAGS_save"
fi
fi
+AC_SUBST(CDDA_LIBS)
+AC_SUBST(CDDA_CFLAGS)
+
AM_CONDITIONAL(USE_CDDA, [test "$msg_cdda" = "yes"])
dnl *************************************************