summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoss Lagerwall <rosslagerwall@gmail.com>2013-10-11 10:06:30 +0200
committerRoss Lagerwall <rosslagerwall@gmail.com>2013-10-25 21:59:59 +0200
commit20418890e206f0e06e2e98c010733627a144e2fd (patch)
tree8735966b401a131826d3d7d0c548bfdf14710778 /configure.ac
parentf04a331fd84e1de883e52cd768406530465393b7 (diff)
downloadgvfs-20418890e206f0e06e2e98c010733627a144e2fd.tar.gz
http: Clean up usage of libsoup
Use libsoup rather than libsoup-gnome since libsoup-gnome is not required anymore. Bump the libsoup requirement to 2.42 to prevent a build failure with old libsoups (undefined references to soup_session_request_uri). Don't include individual libsoup headers as recommended by the libsoup documentation. https://bugzilla.gnome.org/show_bug.cgi?id=587890
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 65eec6b5..eea65896 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,10 +142,10 @@ HTTP_CFLAGS=
HTTP_LIBS=
if test "x$enable_http" != "xno"; then
- PKG_CHECK_EXISTS(libsoup-gnome-2.4 >= 2.34.0, msg_http=yes)
+ PKG_CHECK_EXISTS(libsoup-2.4 >= 2.42.0, msg_http=yes)
if test "x$msg_http" = "xyes"; then
- PKG_CHECK_MODULES(HTTP, libsoup-gnome-2.4 libxml-2.0)
+ PKG_CHECK_MODULES(HTTP, libsoup-2.4 libxml-2.0)
AC_DEFINE(HAVE_HTTP, 1, [Define to 1 if http/dav is going to be built])
fi
fi