summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoss Lagerwall <rosslagerwall@gmail.com>2014-05-06 19:06:41 +0100
committerRoss Lagerwall <rosslagerwall@gmail.com>2015-02-09 23:29:31 +0000
commit874bc00bd19c6853cedcea610e8ac035c8486ca7 (patch)
treef651f364f810be5ca17713cbc8707234976692ea /configure.ac
parent2fc159a7886a6696ca8caa218897b14150485db3 (diff)
downloadgvfs-874bc00bd19c6853cedcea610e8ac035c8486ca7.tar.gz
Add an nfs backend based on libnfs
Add an nfs backend based on libnfs to make userspace mounting and usage of nfs shares easier. The backend is written in a single-threaded, asynchronous style. Performance measurements show around 60-70 MiB/s throughput on 1GbE. To make use of it, simply mount the share with gvfs-mount or Nautilus with the following syntax: nfs://host/export/path Authentication is simple, based on UNIX uid. Since this is a userspace nfs client, it comes with the caveat that the mount needs to be exported with "insecure" on Linux (or some equivalent for other NFS servers) so that it allows connections from port numbers higher than 1023. Alternatively, a special capability can be given to the binary: sudo setcap 'cap_net_bind_service=+ep' /path/to/executable https://bugzilla.gnome.org/show_bug.cgi?id=738967
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a4adfb54..78b802c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -738,6 +738,27 @@ if test "x$enable_afp" != "xno"; then
fi
AM_CONDITIONAL(USE_AFP, test "x$enable_afp" != "xno")
+dnl *******************
+dnl *** NFS backend ***
+dnl *******************
+AC_ARG_ENABLE(nfs, AS_HELP_STRING([--disable-nfs], [build without NFS support]))
+msg_nfs="no"
+NFS_CFLAGS=
+NFS_LIBS=
+
+if test "x$enable_nfs" != "xno"; then
+ PKG_CHECK_EXISTS([libnfs >= 1.9.7], msg_nfs=yes)
+
+ if test "x$msg_nfs" = "xyes"; then
+ PKG_CHECK_MODULES([NFS],[libnfs >= 1.9.7])
+ AC_DEFINE(HAVE_NFS, 1, [Define to 1 if nfs is going to be built])
+ fi
+fi
+
+AC_SUBST(NFS_CFLAGS)
+AC_SUBST(NFS_LIBS)
+AM_CONDITIONAL(HAVE_NFS, [test "$msg_nfs" = "yes"])
+
dnl ***************************************
dnl *** Check for nl_langinfo constants ***
dnl ***************************************
@@ -949,6 +970,7 @@ echo "
archive support: $msg_archive
AFC support: $msg_afc
AFP support: $msg_afp
+ NFS support: $msg_nfs
DNS-SD support: $msg_avahi
Build HAL volume monitor: $msg_hal (with fast init path: $have_hal_fast_init)
Build GDU volume monitor: $msg_gdu