summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2015-05-19 23:38:11 +0200
committerRoss Lagerwall <rosslagerwall@gmail.com>2015-05-23 21:10:31 +0100
commit39be8b277c666db21965d54d5b72418ce57a450b (patch)
tree692e91e3eb51d991a4c01908daced2fc5fa17e15 /configure.ac
parentae4f39794dce0b9fb795cf1810bfa2f03dcb6f3d (diff)
downloadgvfs-39be8b277c666db21965d54d5b72418ce57a450b.tar.gz
Add support for libsystemd
In systemd v209 the various libsystemd-* libraries were merged into a single libsystemd library. So first check for this library and fall back to libsystemd-login if not found. Bug: https://bugzilla.gnome.org/show_bug.cgi?id=749603 Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=779766
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ee3475d6..bd5c0430 100644
--- a/configure.ac
+++ b/configure.ac
@@ -264,18 +264,20 @@ dnl **********************************
dnl *** Check for libsystemd-login ***
dnl **********************************
-AC_ARG_ENABLE(libsystemd_login, AS_HELP_STRING([--disable-libsystemd-login],[build without liblibsystemd-login]))
+AC_ARG_ENABLE(libsystemd_login, AS_HELP_STRING([--disable-libsystemd-login],[build without libsystemd-login]))
msg_libsystemd_login=no
LIBSYSTEMD_LOGIN_LIBS=
LIBSYSTEMD_LOGIN_CFLAGS=
LIBSYSTEMD_LOGIN_REQUIRED=44
if test "x$enable_libsystemd_login" != "xno"; then
- PKG_CHECK_EXISTS([libsystemd-login >= $LIBSYSTEMD_LOGIN_REQUIRED], msg_libsystemd_login=yes)
+ PKG_CHECK_EXISTS([libsystemd], [msg_libsystemd_login=yes],
+ [PKG_CHECK_EXISTS([libsystemd-login >= $LIBSYSTEMD_LOGIN_REQUIRED], msg_libsystemd_login=yes)])
if test "x$msg_libsystemd_login" = "xyes"; then
- PKG_CHECK_MODULES([LIBSYSTEMD_LOGIN],[libsystemd-login >= $LIBSYSTEMD_LOGIN_REQUIRED])
- AC_DEFINE(HAVE_LIBSYSTEMD_LOGIN, 1, [Define to 1 if liblibsystemd_login is available])
+ PKG_CHECK_MODULES([LIBSYSTEMD_LOGIN],[libsystemd],,
+ [PKG_CHECK_MODULES([LIBSYSTEMD_LOGIN],[libsystemd-login >= $LIBSYSTEMD_LOGIN_REQUIRED])])
+ AC_DEFINE(HAVE_LIBSYSTEMD_LOGIN, 1, [Define to 1 if libsystemd_login is available])
fi
fi