summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Henriksson <andreas@fatal.se>2016-08-11 17:12:14 +0200
committerOndrej Holy <oholy@redhat.com>2016-08-22 10:28:21 +0200
commit2ca6dd976a3e45cca3cdebf8fb9468f62e89947a (patch)
tree4f394bd6d572680bf9d436504bcb2b5cbc8e5691 /configure.ac
parent43ec3ac82aafcb7b889d8dc417e69672fb66ac81 (diff)
downloadgvfs-2ca6dd976a3e45cca3cdebf8fb9468f62e89947a.tar.gz
build: admin backend needs libcap
Make sure to check for libcap availability for building the admin backend to avoid potentially running into: gvfsbackendadmin.c:27:28: fatal error: sys/capability.h: No such file or directory #include <sys/capability.h> ^ compilation terminated. https://bugzilla.gnome.org/show_bug.cgi?id=769747
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ce9c50f8..6ccb1e12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,7 +132,7 @@ AC_ARG_ENABLE([admin], [AS_HELP_STRING([--disable-admin],[build without admin ba
msg_admin=no
if test "x$enable_admin" != "xno"; then
- PKG_CHECK_MODULES([ADMIN], [polkit-gobject-1], [msg_admin=yes])
+ PKG_CHECK_MODULES([ADMIN], [polkit-gobject-1 libcap], [msg_admin=yes])
if test "x$msg_admin" = "xyes"; then
AC_DEFINE([HAVE_ADMIN], 1, [Define to 1 if admin backend is going to be built])