summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2014-03-20 16:44:44 +0100
committerOndrej Holy <oholy@redhat.com>2014-03-27 13:55:33 +0100
commita77cdbac08ca1ff17aeba2323a610a61101387db (patch)
tree8cc463e5f70a8c93bcf6458380caedd54cf36ad3 /configure.ac
parent58b39924ccbcfb2809186432dc1c63a3d040bab5 (diff)
downloadgvfs-a77cdbac08ca1ff17aeba2323a610a61101387db.tar.gz
common: use nl_langinfo constants conditionally
The _NL_ADDRESS_LANG_TERM and _NL_ADDRESS_COUNTRY_AB3 aren't portable. https://bugzilla.gnome.org/show_bug.cgi?id=726707
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 63a5c111..dd459698 100644
--- a/configure.ac
+++ b/configure.ac
@@ -735,6 +735,16 @@ if test "x$enable_afp" != "xno"; then
fi
AM_CONDITIONAL(USE_AFP, test "x$enable_afp" != "xno")
+dnl ***************************************
+dnl *** Check for nl_langinfo constants ***
+dnl ***************************************
+AC_CHECK_DECL(_NL_ADDRESS_LANG_TERM,
+ AC_DEFINE(HAVE_NL_ADDRESS_LANG_TERM, 1, Define to 1 if _NL_ADDRESS_LANG_TERM is declared),,
+ [#include <langinfo.h>])
+AC_CHECK_DECL(_NL_ADDRESS_COUNTRY_AB3,
+ AC_DEFINE(HAVE_NL_ADDRESS_COUNTRY_AB3, 1, Define to 1 if _NL_ADDRESS_COUNTRY_AB3 is declared),,
+ [#include <langinfo.h>])
+
dnl Install bash-completion file?
AC_ARG_ENABLE([bash-completion],
AS_HELP_STRING([--disable-bash-completion],