summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimoc@gnome.org>2015-10-10 15:03:02 -0400
committerCosimo Cecchi <cosimo@endlessm.com>2016-07-13 13:35:14 -0700
commitc7b018d11b9aae5dea4fa436710f0bce78747978 (patch)
tree59fb07700d0ae6060c0f603f0bdd5e96973603f3 /configure.ac
parent535f1e6b5d0d66c0361addde01775c04163fb59a (diff)
downloadgvfs-c7b018d11b9aae5dea4fa436710f0bce78747978.tar.gz
Introduce an admin gvfs backend
The new admin backend is activated through pkexec and allows applications to promote their I/O operations to be privileged. Privilege checking is achieved through polkit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c438294..f226712d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,6 +145,24 @@ fi
AC_SEARCH_LIBS([login_tty], [util], [AC_DEFINE([HAVE_LOGIN_TTY],[],[Whether login_tty is available])])
+dnl ***************************************************
+dnl *** Check if we should build with admin backend ***
+dnl ***************************************************
+AC_ARG_ENABLE([admin], [AS_HELP_STRING([--disable-admin],[build without admin backend])])
+msg_admin=no
+
+if test "x$enable_admin" != "xno"; then
+ PKG_CHECK_MODULES([ADMIN], [polkit-gobject-1], [msg_admin=yes])
+
+ if test "x$msg_admin" = "xyes"; then
+ AC_DEFINE([HAVE_ADMIN], 1, [Define to 1 if admin backend is going to be built])
+ fi
+fi
+
+AC_SUBST(ADMIN_CFLAGS)
+AC_SUBST(ADMIN_LIBS)
+AM_CONDITIONAL([HAVE_ADMIN], [test "$msg_admin" = "yes"])
+
dnl **************************************************
dnl *** Check if we should build with http backend ***
dnl **************************************************