summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2016-04-04 10:57:20 +0200
committerOndrej Holy <oholy@redhat.com>2016-06-07 15:13:40 +0200
commit66df8f2afbe46e27052f98321c633ccecebbafb1 (patch)
treebaf7e6d4b33428acb4e66a3303065bb7c965bee8 /configure.ac
parent2be06cd34bb660fa7f05bc27bc728e9ddce46c7d (diff)
downloadgvfs-66df8f2afbe46e27052f98321c633ccecebbafb1.tar.gz
build: Fix all statfs() tests failing
The current statfs() compilation tests all fail because statfs() expects the first argument to be non-null. Pass a dummy path instead of NULL to satisfy the compiler. The patch is taken from GLib, see Bug 764574. https://bugzilla.gnome.org/show_bug.cgi?id=767331
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a6085e1a..ddfad4a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -835,7 +835,7 @@ if test "$ac_cv_func_statfs" = yes ; then
#ifdef HAVE_SYS_STATFS_H
#include <sys/statfs.h>
#endif], [struct statfs st;
- statfs(NULL, &st);],[
+ statfs("/", &st);],[
AC_MSG_RESULT([2])
AC_DEFINE(STATFS_ARGS, 2, [Number of arguments to statfs()])],[
AC_TRY_COMPILE([#include <unistd.h>
@@ -851,7 +851,7 @@ if test "$ac_cv_func_statfs" = yes ; then
#ifdef HAVE_SYS_STATFS_H
#include <sys/statfs.h>
#endif], [struct statfs st;
- statfs(NULL, &st, sizeof (st), 0);],[
+ statfs("/", &st, sizeof (st), 0);],[
AC_MSG_RESULT([4])
AC_DEFINE(STATFS_ARGS, 4, [Number of arguments to statfs()])],[
AC_MSG_RESULT(unknown)