summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2016-10-25 09:00:05 +0200
committerOndrej Holy <oholy@redhat.com>2016-12-12 14:28:57 +0100
commit63b45093ccbdba33586db740ff4f5da6506caff6 (patch)
treed6bd1342c621ad15c00799e98ff05b0eb73b847f /configure.ac
parentaa61b05888f2e588acf8a1febb5dd20d8657d753 (diff)
downloadgvfs-63b45093ccbdba33586db740ff4f5da6506caff6.tar.gz
trash: Correctly determine fs type for paths with symlinks
If, for example, "/home" is a symlink to "/mnt/home", and the users's $HOME is "/home/user", then the code won't correctly recognize unix mount, because it just walks up the path removing trailing components. Consequently, "/" is used to determine filesystem type instead of "/mnt/home". It will cause problems if "/mnt/home" is e.g. NFS, which is handled differently than local filesystem. It uses newly added g_unix_mount_for. Bump GLib dependency accordingly. https://bugzilla.gnome.org/show_bug.cgi?id=771431
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fa16230d..31bb01d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,7 +61,7 @@ GTK_DOC_CHECK
DISTCHECK_CONFIGURE_FLAGS="--enable-gtk-doc"
AC_SUBST(DISTCHECK_CONFIGURE_FLAGS)
-PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.49.4 gobject-2.0 gmodule-no-export-2.0 gio-unix-2.0 gio-2.0])
+PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.51.0 gobject-2.0 gmodule-no-export-2.0 gio-unix-2.0 gio-2.0])
AC_ARG_WITH([dbus_service_dir],
[AS_HELP_STRING([--with-dbus-service-dir=PATH],[choose directory for dbus service files, [default=PREFIX/share/dbus-1/services]])],