summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2016-11-08 13:50:27 +0100
committerOndrej Holy <oholy@redhat.com>2017-03-23 16:55:33 +0100
commitd22a127d79f5c7f8d918b86506d661b702f5ec54 (patch)
treea990cef66e7b02218f90c57c3ad2bb689f7b0612 /configure.ac
parente0905e89c606596fb88bf1127497077577e6347b (diff)
downloadgvfs-d22a127d79f5c7f8d918b86506d661b702f5ec54.tar.gz
google: Fix reported file size
Ligdata recently added API to obtain a real file size. Use gdata_documents_entry_get_file_size if libgdata 0.17.7 is available instead of gdata_documents_entry_get_quota_used, which returns 0 in some cases (e.g. shared files). https://bugzilla.gnome.org/show_bug.cgi?id=773053
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b993d39..32ef98e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -391,6 +391,11 @@ if test "x$enable_google" != "xno" ; then
if test "x$msg_google" = "xyes"; then
PKG_CHECK_MODULES([GOOGLE], [goa-1.0 libgdata])
AC_DEFINE([HAVE_GOOGLE], 1, [Define to 1 if Google is going to be built])
+
+ PKG_CHECK_MODULES(LIBGDATA_0_17_7, libgdata >= 0.17.7,
+ AC_DEFINE(HAVE_LIBGDATA_0_17_7, 1, [Define to 1 if libgdata 0.17.7 is available]),
+ []
+ )
fi
fi