summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Kellner <gicmo@src.gnome.org>2008-07-01 14:16:31 +0000
committerChristian Kellner <gicmo@src.gnome.org>2008-07-01 14:16:31 +0000
commitd2136a608aa5dd6607e66c0cc374804bc8339f88 (patch)
treeff656ab88b01de1e37583e94cefa97a132ba7f0a /configure.ac
parent0d8026356b42b2f90172e02d68d439078bee3188 (diff)
downloadgvfs-d2136a608aa5dd6607e66c0cc374804bc8339f88.tar.gz
Correctly check the right libhal for hal features
* configure.ac: Correctly check the right libhal for hal features. Patch from Andreas Rottmann <a.rottmann@gmx.at> (#537149) svn path=/trunk/; revision=1814
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3dd2d060..d55a6b52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,10 +214,13 @@ if test "x$enable_hal" != "xno"; then
if test "x$msg_hal" == "xyes"; then
PKG_CHECK_MODULES([HAL],[hal >= $HAL_REQUIRED])
AC_DEFINE(HAVE_HAL, 1, [Define to 1 if HAL is available])
+ save_libs="$LIBS"
+ LIBS="$HAL_LIBS"
AC_CHECK_LIB(hal, libhal_get_all_devices_with_properties, have_hal_fast_init=yes)
if test "x$have_hal_fast_init" == "xyes"; then
AC_DEFINE(HAVE_HAL_FAST_INIT, 1, [Define to 1 if libhal_get_all_devices_with_properties is available])
fi
+ LIBS="$save_libs"
fi
fi