summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2008-02-25 11:17:08 +0000
committerAlexander Larsson <alexl@src.gnome.org>2008-02-25 11:17:08 +0000
commitfd09daa489fbf2158472c4a7f3b4e92bf8f4ec0c (patch)
treeacfdb20f29bf00584ade92c855d65c7dec241264 /configure.ac
parent08ef6a83f785d5ac1eb423f8253c6455ad596232 (diff)
downloadgvfs-fd09daa489fbf2158472c4a7f3b4e92bf8f4ec0c.tar.gz
Prefer to return a GDaemonMount from an existing GDaemonVolumeMonitor
2008-02-24 David Zeuthen <davidz@redhat.com> * client/gdaemonfile.c: * client/gdaemonvolumemonitor.c: * client/gdaemonvolumemonitor.h: Prefer to return a GDaemonMount from an existing GDaemonVolumeMonitor rather than rolling our own for GDaemonFile's g_file_find_enclosing_mount() implementation. This is to ensure that g_mount_get_volume() will work properly with mounts that are adopted by GVolume objects from other volume monitors. * configure.ac: Check for libgphoto2 * daemon/Makefile.am: * daemon/gvfsbackendcdda.c: Use HAL to detect when the disc is removed and then forcibly unmount the mount. Report size of disc. Hint the file manager to preview files. * hal/ghaldrive.c: * hal/ghalmount.c: * hal/ghalvolume.c: * hal/ghalvolumemonitor.c: * hal/ghalvolumemonitor.h: * hal/hal-pool.c: Ensure that audio and blank CD's are displayed (#514139). Read info.desktop.[icon|name] properties from hal and use these if found. Use proper icon for audio players and make the gphoto2 detection support it as well. Also check for subsystem when filtering on hal capabilities. Also revert the commit to ignore NFS mounts as gio will now only report an user visible mount if it's in /media or $HOME. Make LUKS encrypted volumes work. * daemon/Makefile.am: * daemon/gphoto2.mount.in: * daemon/gvfsbackendgphoto2.c: Land the gphoto2 backend. * programs/Makefile.am: * programs/gvfs-ls.c: Make the --hidden option work. Default to short listing and add a --long option. Implement new options --show-completions and --show-mounts that can be used for shell completions. * programs/gvfs-tree.c: New program * programs/gvfs-bash-completion.sh: Bash completion for gvfs; uses the new --show-completions and --show-mounts options in gvfs-ls. svn path=/trunk/; revision=1359
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b60a5a3d..031dcf92 100644
--- a/configure.ac
+++ b/configure.ac
@@ -240,6 +240,43 @@ AC_SUBST(HAL_CFLAGS)
AM_CONDITIONAL(USE_HAL, [test "$msg_hal" = "yes"])
+dnl *************************
+dnl *** Check for gphoto2 ***
+dnl *************************
+AC_ARG_ENABLE(hal, [ --disable-gphoto2 build without gphoto2 support])
+msg_gphoto2=no
+GPHOTO2_LIBS=
+GPHOTO2_CFLAGS=
+
+if test "x$enable_gphoto2" != "xno"; then
+ PKG_CHECK_EXISTS(libgphoto2, msg_gphoto2=yes)
+
+ # Need OS tweaks in hal volume monitor backend
+ case "$host" in
+ *-linux*)
+ use_gphoto2=yes
+ ;;
+ *)
+ use_gphoto2=no
+ ;;
+ esac
+
+ if test "x$msg_gphoto2" == "xyes"; then
+ if test "x$use_gphoto2" == "xyes"; then
+ PKG_CHECK_MODULES(GPHOTO2, libgphoto2)
+ AC_DEFINE(HAVE_GPHOTO2, 1, [Define to 1 if gphoto2 is available])
+ else
+ AC_MSG_WARN([Not building with gphoto2 support. Need OS tweaks in hal volume monitor.])
+ msg_gphoto2=no
+ fi
+ fi
+fi
+
+AC_SUBST(GPHOTO2_LIBS)
+AC_SUBST(GPHOTO2_CFLAGS)
+
+AM_CONDITIONAL(USE_GPHOTO2, [test "$msg_gphoto2" = "yes"])
+
dnl *******************************
dnl *** Check for GNOME Keyring ***
dnl *******************************
@@ -404,6 +441,7 @@ echo "
Samba support: $msg_samba
FUSE support: $msg_fuse
CDDA support: $msg_cdda
+ Gphoto2 support: $msg_gphoto2
GConf support: $msg_gconf
DNS-SD support: $msg_avahi
Use HAL for volume monitor: $msg_hal (with fast init path: $have_hal_fast_init)