summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimoc@gnome.org>2009-02-13 14:46:38 +0000
committerCosimo Cecchi <cosimoc@src.gnome.org>2009-02-13 14:46:38 +0000
commit0d1c06f9b8a8430a42bb1f7e84e6c702126a4bdb (patch)
tree1f57fd5e267f7d16f530a1715fa37471f4d0895c /configure.ac
parent5a629953e439be6b2bebb9fca33c320ba9f86b09 (diff)
downloadgvfs-0d1c06f9b8a8430a42bb1f7e84e6c702126a4bdb.tar.gz
Bug 531705 – Won't build with libarchive 1.3.1
2009-02-13 Cosimo Cecchi <cosimoc@gnome.org> Bug 531705 – Won't build with libarchive 1.3.1 * configure.ac: check for archive_entry_filetype() instead of archive_read_open(). Patch from Tom Parker. svn path=/trunk/; revision=2213
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ad882d0c..37550c19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -449,7 +449,7 @@ if test "x$enable_archive" != "xno"; then
LDFLAGS_save="$LDFLAGS"
LDFLAGS="$LDFLAGS -L$with_archive_libs"
- AC_CHECK_LIB(archive, archive_read_open, archive_libs="yes", archive_libs="no")
+ AC_CHECK_LIB(archive, archive_entry_filetype, archive_libs="yes", archive_libs="no")
LDFLAGS="$LDFLAGS_save"
if test "x${archive_libs}" != "xno"; then
AC_DEFINE(HAVE_ARCHIVE,, [Define to 1 if you have the libarchive library])
@@ -460,7 +460,7 @@ if test "x$enable_archive" != "xno"; then
ARCHIVE_LIBS="-larchive"
fi
else
- AC_CHECK_LIB(archive, archive_read_open, archive_old_libs="yes", archive_old_libs="no")
+ AC_CHECK_LIB(archive, archive_entry_filetype, archive_old_libs="yes", archive_old_libs="no")
if test "x${archive_old_libs}" != "xno"; then
msg_archive="Too old, need at least archive 3.0.22"
fi