summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-09-03 17:53:32 +0200
committerAlexander Larsson <alexl@redhat.com>2015-09-03 17:53:32 +0200
commit59325dfbe1f855434f87b7791d11175bfdfb9766 (patch)
tree77827f15377eb7d82aa6f7889962d5397ed37a15 /daemon/Makefile.am
parent7fd91dfb7c48ed31688bcfcdc2dd5ab3f37a7377 (diff)
downloadgvfs-59325dfbe1f855434f87b7791d11175bfdfb9766.tar.gz
Make all gvfs daemons own a name under org.gtk.vfs.*
This allows you to easily allow access to gvfs from a sandbox. Just give it talk access to org.gtk.vfs.* and everything will work. This change does three things: Change the existing mountpoint dbus names from org.gtk.vfs.mountpoint.foo to org.gtk.vfs.mountpoint_foo For other mountpoints, always own: org.gtk.vfs.mountpoint_$pid Change the dbus name of the volume monitors from org.gtk.Private.fooMonitor to org.gtk.vfs.fooMonitor
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 59f4a55d..a970bff6 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -261,7 +261,7 @@ gvfsd_smb_browse_SOURCES = \
gvfsd_smb_browse_CPPFLAGS = \
$(flags) \
-DBACKEND_HEADER=gvfsbackendsmbbrowse.h \
- -DMOUNTABLE_DBUS_NAME=org.gtk.vfs.mountpoint.smb_browse \
+ -DMOUNTABLE_DBUS_NAME=org.gtk.vfs.mountpoint_smb_browse \
-DMAX_JOB_THREADS=1 \
-DBACKEND_TYPES='"smb-network", G_VFS_TYPE_BACKEND_SMB_BROWSE,"smb-server", G_VFS_TYPE_BACKEND_SMB_BROWSE,'
@@ -486,7 +486,7 @@ gvfsd_http_SOURCES = \
gvfsd_http_CPPFLAGS = \
$(flags) \
-DBACKEND_HEADER=gvfsbackendhttp.h \
- -DMOUNTABLE_DBUS_NAME=org.gtk.vfs.mountpoint.http \
+ -DMOUNTABLE_DBUS_NAME=org.gtk.vfs.mountpoint_http \
-DDEFAULT_BACKEND_TYPE=http \
-DMAX_JOB_THREADS=1 \
$(HTTP_CFLAGS) \