summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2009-06-02 13:19:51 +0200
committerBenjamin Otte <otte@gnome.org>2009-06-11 10:05:40 +0200
commite62142b001e218d268a85f2f90993cdf42148fae (patch)
tree4948320f6778cb04118a1c6541291eac338fed73 /daemon/Makefile.am
parent2f5c4dcfd579f9b9cceb8eb08b71d4318e9c03b6 (diff)
downloadgvfs-e62142b001e218d268a85f2f90993cdf42148fae.tar.gz
[FTP] introduce GVfsFtpTask
split out the old FtpConnection struct into a separate GVfsFtpTask structure that acts as a one-stop solution to vfuncs. It keeps track of all important structures: - the backend - the current job - the potential connection to the server - the error state during the lifetime of a backend vfunc and supplies convenience functions to ease implementing these vfuncs. The API of gvfsftptask.h is documented.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index af8d663b..c9e17ae7 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -232,6 +232,7 @@ gvfsd_obexftp_LDADD = $(OBEXFTP_LIBS) $(XML_LIBS) $(HAL_LIBS) $(libraries)
gvfsd_ftp_SOURCES = \
gvfsftpconnection.c gvfsftpconnection.h \
gvfsftpfile.c gvfsftpfile.h \
+ gvfsftptask.c gvfsftptask.h \
gvfsbackendftp.c gvfsbackendftp.h \
ParseFTPList.c ParseFTPList.h \
daemon-main.c daemon-main.h \