summaryrefslogtreecommitdiff
path: root/daemon/meson.build
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackware.com>2019-07-18 03:38:41 -0500
committerRobby Workman <rworkman@slackware.com>2019-07-18 21:46:00 -0500
commitf361857c315279ebebfc57aaafd99dd934a09607 (patch)
treeb1bc5fc9a60e4c1ab0a30fb881feeef5738c701c /daemon/meson.build
parent95511d5dbf15952aa4d9d05041997f5e100e576a (diff)
downloadgvfs-f361857c315279ebebfc57aaafd99dd934a09607.tar.gz
daemon/meson.build: define gvfs_rpath for libgvfsdaemon.so
On Slackware development branch with gvfs-1.40.2, I just noticed this: # ldd /usr/lib64/gvfs/libgvfsdaemon.so | grep "not found" libgvfscommon.so => not found After some backtracking, it seems that this first occurred in the switchover from autotools to meson in the 1.36.x --> 1.38.x bump. Big thanks to Cogitri in #gnome/irc.gnome.org for the patience and assistance with troubleshooting this. Signed-off-by: Robby Workman <rworkman@slackware.com>
Diffstat (limited to 'daemon/meson.build')
-rw-r--r--daemon/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/daemon/meson.build b/daemon/meson.build
index 2d253e3b..dffeef3e 100644
--- a/daemon/meson.build
+++ b/daemon/meson.build
@@ -123,6 +123,7 @@ libgvfsdaemon = shared_library(
dependencies: deps,
c_args: cflags,
install: true,
+ install_rpath: gvfs_rpath,
install_dir: gvfs_pkglibdir,
)