summaryrefslogtreecommitdiff
path: root/daemon/meson.build
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2021-05-12 10:19:56 +0200
committerOndrej Holy <oholy@redhat.com>2021-06-07 07:28:17 +0000
commit141eee12c5c6c37e098cef2f1a80d1df58168d5b (patch)
tree1dc3fdeedb85fad3fc12b85255c5bf7db6c06526 /daemon/meson.build
parentdede4bbda08a02c47b917c03eaf59e994b15edbb (diff)
downloadgvfs-141eee12c5c6c37e098cef2f1a80d1df58168d5b.tar.gz
admin: Make the privileged group configurable
Currently, `wheel` group is hardcoded in the `.rules` file which is there to prevent redundant password prompt when starting gvfsd-admin. The Debian based systems obviously uses `sudo` group instead of `wheel`. Let's make the privileged group configurable. https://gitlab.gnome.org/GNOME/gvfs/-/issues/565
Diffstat (limited to 'daemon/meson.build')
-rw-r--r--daemon/meson.build11
1 files changed, 9 insertions, 2 deletions
diff --git a/daemon/meson.build b/daemon/meson.build
index dffeef3e..c89ef407 100644
--- a/daemon/meson.build
+++ b/daemon/meson.build
@@ -374,8 +374,15 @@ if enable_admin
install_dir: gvfs_datadir / 'polkit-1/actions',
)
- install_data(
- gvfs_namespace + '.file-operations.rules',
+ rules = gvfs_namespace + '.file-operations.rules'
+
+ rules_conf = configuration_data()
+ rules_conf.set('PRIVILEGED_GROUP', privileged_group)
+
+ configure_file(
+ input: rules + '.in',
+ output: rules,
+ configuration: rules_conf,
install_dir: gvfs_datadir / 'polkit-1/rules.d',
)
endif