summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2018-09-12 15:28:51 +0200
committerOndrej Holy <oholy@redhat.com>2018-09-21 08:23:03 +0000
commit6c8bc39f570ea82cf14e83ce7d1dbdbe569d09d1 (patch)
tree2833af1fcb0c1764c78c1e332581d6ef335b0b8f /meson.build
parent62f1a8c6c8f0f077781e47694969f9c1384ac6c5 (diff)
downloadgvfs-6c8bc39f570ea82cf14e83ce7d1dbdbe569d09d1.tar.gz
smbbrowse: Force NT1 protocol version for workgroup support
"Windows Network" doesn't work with recent samba versions, because "client max protocol" has been changed from NT1 to SMB3 recently. NT1 is mandatory for workgroup support. Let's force NT1 using the newly added smbc_setOptionProtocols API if available. But force this only when neither hostname, nor IP address is used. This among others prevents complete breakage if NT1 is disabled on server. Use GResolver to implement this heuristic. https://bugzilla.gnome.org/show_bug.cgi?id=780958
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6b760983..59f840a4 100644
--- a/meson.build
+++ b/meson.build
@@ -387,6 +387,8 @@ config_h.set10('HAVE_LIBUSB', enable_libusb)
enable_samba = get_option('smb')
if enable_samba
smbclient_dep = dependency('smbclient')
+
+ config_h.set('HAVE_SMBC_SETOPTIONPROTOCOLS', cc.has_function('smbc_setOptionProtocols', dependencies: smbclient_dep))
endif
# *** Check for libarchive ***