summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-12-17 16:19:19 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2019-01-21 21:18:06 +0100
commitce13717c433c841f7b3e749ccedcdfc830c4f761 (patch)
tree7979b40dc0d0cf7b90f3f44330ae8ba2a399f242 /meson.build
parentb7ca7962e7dcf1508130ffeed515f26036ab2176 (diff)
downloadgvfs-ce13717c433c841f7b3e749ccedcdfc830c4f761.tar.gz
build: Use / instead of join_paths
Since meson 0.49, the `/` character can be used to join paths[0], so all the instances of `join_paths` have been replaced. [0] http://mesonbuild.com/Release-notes-for-0-49-0.html#joining-paths-with-
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 12 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index 03956566..e3aeeae9 100644
--- a/meson.build
+++ b/meson.build
@@ -10,21 +10,21 @@ gvfs_name = meson.project_name()
gvfs_version = meson.project_version()
gvfs_prefix = get_option('prefix')
-gvfs_datadir = join_paths(gvfs_prefix, get_option('datadir'))
-gvfs_libdir = join_paths(gvfs_prefix, get_option('libdir'))
-gvfs_libexecdir = join_paths(gvfs_prefix, get_option('libexecdir'))
-gvfs_localedir = join_paths(gvfs_prefix, get_option('localedir'))
-gvfs_mandir = join_paths(gvfs_prefix, get_option('mandir'))
+gvfs_datadir = gvfs_prefix / get_option('datadir')
+gvfs_libdir = gvfs_prefix / get_option('libdir')
+gvfs_libexecdir = gvfs_prefix / get_option('libexecdir')
+gvfs_localedir = gvfs_prefix / get_option('localedir')
+gvfs_mandir = gvfs_prefix / get_option('mandir')
-gvfs_pkgdatadir = join_paths(gvfs_datadir, gvfs_name)
-gvfs_pkglibdir = join_paths(gvfs_libdir, gvfs_name)
+gvfs_pkgdatadir = gvfs_datadir / gvfs_name
+gvfs_pkglibdir = gvfs_libdir / gvfs_name
gvfs_rpath = gvfs_pkglibdir
-gvfs_remote_volume_monitors_dir = join_paths(gvfs_pkgdatadir, 'remote-volume-monitors')
+gvfs_remote_volume_monitors_dir = gvfs_pkgdatadir / 'remote-volume-monitors'
-gvfs_mountdir = join_paths(gvfs_pkgdatadir, 'mounts')
-gvfs_schema_dir = join_paths(gvfs_datadir, 'glib-2.0', 'schemas')
+gvfs_mountdir = gvfs_pkgdatadir / 'mounts'
+gvfs_schema_dir = gvfs_datadir / 'glib-2.0/schemas'
gvfs_namespace = 'org.gtk.vfs'
@@ -218,7 +218,7 @@ endif
add_project_arguments(common_flags, language: 'c')
version_script_ldflag = '-Wl,--version-script'
-have_version_script = cc.has_link_argument('@0@,@1@'.format(version_script_ldflag, join_paths(meson.current_source_dir(), 'client', 'symbol.map')))
+have_version_script = cc.has_link_argument('@0@,@1@'.format(version_script_ldflag, meson.current_source_dir() / 'client/symbol.map'))
gio_dep = dependency('gio-2.0')
gio_unix_dep = dependency('gio-unix-2.0')
@@ -456,7 +456,7 @@ pkg = import('pkgconfig')
service_conf = configuration_data()
service_conf.set('libexecdir', gvfs_libexecdir)
-po_dir = join_paths(meson.source_root(), 'po')
+po_dir = meson.source_root() / 'po'
top_inc = include_directories('.')