summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-12-18 08:59:55 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2019-01-21 21:18:06 +0100
commit8b7864294a2bb2360cc82c90c2d8a77f4e85ee27 (patch)
treeb4dd2c5e3ba9e513e3af13ddae285f75bbbe13a4 /meson.build
parentd4684f505d8f8cbd5d3f85c31dde9b225f769aa3 (diff)
downloadgvfs-8b7864294a2bb2360cc82c90c2d8a77f4e85ee27.tar.gz
build: Avoid extra variable on compiler flag checking
The use of an extra variable can be avoided and still maintain readibility when checking compiler flags, so the build commands have been changed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 787be552..a774ff87 100644
--- a/meson.build
+++ b/meson.build
@@ -213,16 +213,14 @@ endforeach
common_flags = ['-DHAVE_CONFIG_H']
if gvfs_debug
- test_cflags = [
+ common_flags += cc.get_supported_arguments([
'-Wcast-align',
'-Wmissing-declarations',
'-Wmissing-prototypes',
'-Wnested-externs',
'-Wno-sign-compare',
'-Wno-strict-aliasing',
- ]
-
- common_flags += cc.get_supported_arguments(test_cflags)
+ ])
endif
add_project_arguments(common_flags, language: 'c')