summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2019-08-06 18:02:02 +0200
committerOndrej Holy <oholy@redhat.com>2019-11-05 11:40:00 +0100
commitf581a0aea03844752eff655393c5ddfc0e6d68df (patch)
tree831cd43418a2ea40f648b347435e8438eab5ac68 /meson.build
parente4b39b1b51db2b09bec6b231b0009a3d5b343699 (diff)
downloadgvfs-f581a0aea03844752eff655393c5ddfc0e6d68df.tar.gz
smb: Improve enumeration performance
The samba backend calls stat for each file during the enumeration job. Unfortunately, this is significantly slower with the recent samba versions. However, smbc_readdirplus2() has been recently added and it can be used to improve the performance as all the necessary info is transferred in one network request. Let's use smbc_readdirplus2() if available. See: https://gitlab.com/samba-team/samba/merge_requests/302 Relates: https://gitlab.gnome.org/GNOME/gvfs/issues/306
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 22b37da4..30b9abec 100644
--- a/meson.build
+++ b/meson.build
@@ -394,6 +394,7 @@ if enable_samba
smbclient_dep = dependency('smbclient')
config_h.set('HAVE_SMBC_SETOPTIONPROTOCOLS', cc.has_function('smbc_setOptionProtocols', dependencies: smbclient_dep))
+ config_h.set('HAVE_SMBC_READDIRPLUS2', cc.has_function('smbc_readdirplus2', dependencies: smbclient_dep))
endif
# *** Check for libarchive ***