summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-12-18 08:49:07 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2019-01-21 21:18:06 +0100
commitd4684f505d8f8cbd5d3f85c31dde9b225f769aa3 (patch)
treeb65e6fb89609ad7a30857bb86b7e12fe5c22b39b /meson.build
parent7fde89de74f2d25cf2c074d227a7ffd3a732647d (diff)
downloadgvfs-d4684f505d8f8cbd5d3f85c31dde9b225f769aa3.tar.gz
build: Define meson information early
The used meson modules, default directories and includes have been moved to the start of the build file, just after project related information, so they are available early. The way `po` directory path is defined has also been changed to avoid the use of the `source_root` function.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 11 insertions, 11 deletions
diff --git a/meson.build b/meson.build
index ce573125..787be552 100644
--- a/meson.build
+++ b/meson.build
@@ -29,6 +29,17 @@ gvfs_namespace = 'org.gtk.vfs'
gvfs_debug = get_option('buildtype').contains('debug')
+gnome = import('gnome')
+i18n = import('i18n')
+pkg = import('pkgconfig')
+
+po_dir = meson.current_source_dir() / 'po'
+
+top_inc = include_directories('.')
+
+service_conf = configuration_data()
+service_conf.set('libexecdir', gvfs_prefix / gvfs_libexecdir)
+
cc = meson.get_compiler('c')
config_h = configuration_data()
@@ -453,17 +464,6 @@ endif
enable_devel_utils = get_option('devel_utils')
enable_installed_tests = get_option('installed_tests')
-gnome = import('gnome')
-i18n = import('i18n')
-pkg = import('pkgconfig')
-
-service_conf = configuration_data()
-service_conf.set('libexecdir', gvfs_prefix / gvfs_libexecdir)
-
-po_dir = meson.source_root() / 'po'
-
-top_inc = include_directories('.')
-
subdir('common')
subdir('metadata')
subdir('client')