summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorMayank Sharma <mayank8019@gmail.com>2019-08-28 08:57:32 +0530
committerOndrej Holy <oholy@redhat.com>2020-01-31 06:54:02 +0000
commitcaf866440e0fb2a7a0e4b105c8a5b8c1e7875654 (patch)
tree320de6853c0e27bd865c9341c5a468b5c764dfc5 /test/meson.build
parenteb21143f49ca5ebea73b78bb61b4ac1fda402a97 (diff)
downloadgvfs-caf866440e0fb2a7a0e4b105c8a5b8c1e7875654.tar.gz
google: Added tests for the Google Backend and updated tests/meson.build
A new set of tests have been added to test the newly implemented functionality in the Google Backend. The tests use the first GMount (linked to a valid Google account) to obtain an email address and create a libgdata service for contacting the Drive API. These tests use the GIO API directly to perform various operations automatically.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 552a30cf..7b6a9416 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -47,17 +47,21 @@ if enable_devel_utils
'benchmark-posix-big-files',
'benchmark-posix-small-files',
'test-query-info-stream',
+ 'google'
]
deps = [
gio_dep,
glib_dep,
+ libgdata_dep,
+ goa_dep
]
foreach test: tests
executable(
test,
test + '.c',
+ c_args: ['-DG_LOG_DOMAIN="@0@"'.format(test)],
include_directories: top_inc,
dependencies: deps,
)