summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
new file mode 100644
index 00000000..4bd74aa6
--- /dev/null
+++ b/client/Makefile.am
@@ -0,0 +1,30 @@
+NULL =
+
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/gvfs \
+ -I$(top_srcdir)/daemon \
+ $(GLIB_CFLAGS) $(DBUS_CFLAGS) \
+ -DG_LOG_DOMAIN=\"GVFS\" -DG_DISABLE_DEPRECATED \
+ -DDBUS_API_SUBJECT_TO_CHANGE
+
+module_flags = -export_dynamic -avoid-version -module -no-undefined
+modulesdir = $(libdir)/gio/gvfs-modules
+
+modules_LTLIBRARIES = libgvfsdbus.la
+
+libgvfsdbus_la_LDFLAGS = $(module_flags)
+libgvfsdbus_la_SOURCES = \
+ gsysutils.c gsysutils.h \
+ gdbusutils.c gdbusutils.h \
+ gvfsimpldaemon.c gvfsimpldaemon.h \
+ gfiledaemon.c gfiledaemon.h \
+ gfiledaemonlocal.c gfiledaemonlocal.h \
+ gvfsuriutils.c gvfsuriutils.h \
+ gfileinputstreamdaemon.c gfileinputstreamdaemon.h \
+ gfileenumeratordaemon.c gfileenumeratordaemon.h \
+ gvfsdaemondbus.c \
+ $(NULL)
+
+libgvfsdbus_la_LIBADD = \
+ $(top_builddir)/gio/libgio.la \
+ $(DBUS_LIBS) \
+ $(GLIB_LIBS)