summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build22
1 files changed, 11 insertions, 11 deletions
diff --git a/man/meson.build b/man/meson.build
index a333194a..f64da677 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -14,20 +14,20 @@ xsltproc_cmd = [
'@INPUT@',
]
-mans = [
- ['gvfs', '7'],
- ['gvfsd', '1'],
- ['gvfsd-fuse', '1'],
- ['gvfsd-metadata', '1'],
-]
+mans = {
+ 'gvfs': '7',
+ 'gvfsd': '1',
+ 'gvfsd-fuse': '1',
+ 'gvfsd-metadata': '1',
+}
-foreach man: mans
+foreach program, section: mans
custom_target(
- man[0] + man[1],
- input: man[0] + '.xml',
- output: '@BASENAME@.' + man[1],
+ program + section,
+ input: program + '.xml',
+ output: '@BASENAME@.' + section,
command: xsltproc_cmd,
install: true,
- install_dir: gvfs_mandir / ('man' + man[1]),
+ install_dir: gvfs_mandir / ('man' + section),
)
endforeach