summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 15a78e47..665d284d 100644
--- a/meson.build
+++ b/meson.build
@@ -453,6 +453,13 @@ if enable_nfs
libnfs_dep = dependency('libnfs', version: '>= 1.9.8')
endif
+# *** SFTP backend ***
+enable_sftp = get_option('sftp')
+if enable_sftp
+ ssh = find_program('ssh', required: false)
+ assert(ssh.found(), 'SFTP backend requested but a ssh client is required')
+endif
+
# *** Enable development utils ***
enable_devel_utils = get_option('devel_utils')
enable_installed_tests = get_option('installed_tests')
@@ -523,6 +530,7 @@ output += ' gphoto2: ' + enable_gphoto2.to_string() + '\n'
output += ' http: ' + enable_http.to_string() + '\n'
output += ' mtp: ' + enable_mtp.to_string() + '\n'
output += ' nfs: ' + enable_nfs.to_string() + '\n'
+output += ' sftp: ' + enable_sftp.to_string() + '\n'
output += ' smb: ' + enable_samba.to_string() + '\n'
output += ' udisks2: ' + enable_udisks2.to_string() + '\n'
output += '\n'