summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2012-06-29 01:33:17 +0100
committerIan Lynagh <igloo@earth.li>2012-06-29 12:02:08 +0100
commit5ddc841a547d2d37428280b04c071a1d4b83e10d (patch)
tree6154172433fafad4c2dcaf299a475159566149f7 /configure.ac
parent30b5ba9b86610f38da704d6b7426cd776e3fbbe4 (diff)
downloadhaskell-5ddc841a547d2d37428280b04c071a1d4b83e10d.tar.gz
On Windows, detect if DLLs have too many symbols; trac #5987
The test isn't very pretty; it involves trawling through the objdump -p output. I couldn't find an easier way, unfortuantely.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e1b4db0d73..f7862ecfc4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -336,6 +336,7 @@ then
CC="${mingwbin}gcc.exe"
LD="${mingwbin}ld.exe"
NM="${mingwbin}nm.exe"
+ OBJDUMP="${mingwbin}objdump.exe"
fp_prog_ar="${mingwbin}ar.exe"
if ! test -d inplace/perl ||
@@ -446,6 +447,12 @@ FP_ARG_WITH_PATH_GNU_PROG([NM], [nm], [nm])
NmCmd="$NM"
AC_SUBST([NmCmd])
+dnl ** Which objdump to use?
+dnl --------------------------------------------------------------
+FP_ARG_WITH_PATH_GNU_PROG([OBJDUMP], [objdump], [objdump])
+ObjdumpCmd="$OBJDUMP"
+AC_SUBST([ObjdumpCmd])
+
dnl ** Which LLVM llc to use?
dnl --------------------------------------------------------------
FP_ARG_WITH_PATH_GNU_PROG_OPTIONAL([LLC], [llc])