summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2011-06-22 19:10:03 +0100
committerIan Lynagh <igloo@earth.li>2011-06-22 19:32:25 +0100
commit6ecb8d38b38e134760cf6fd88b078b224b2d8424 (patch)
tree5eb2eaf0d5f3d8d72a304c9538ac91964d4043c6 /configure.ac
parent1003471ce94d752eda3977c9fa07cbe32ac149f2 (diff)
downloadhaskell-6ecb8d38b38e134760cf6fd88b078b224b2d8424.tar.gz
Move more commands into the settings file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 680456dfc3..9d3bb3d3bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -576,12 +576,24 @@ if test "$windows" = YES
then
SettingsCCompilerCommand='$topdir/../mingw/bin/gcc.exe'
SettingsCCompilerFlags=''
+ SettingsPerlCommand='$topdir/../perl/perl.exe'
+ SettingsDllWrapCommand='$topdir/../mingw/bin/dllwrap.exe'
+ SettingsWindresCommand='$topdir/../mingw/bin/windres.exe'
+ SettingsTouchCommand='$topdir/touch.exe'
else
SettingsCCompilerCommand="$WhatGccIsCalled"
SettingsCCompilerFlags="$CONF_CC_OPTS_STAGE2"
+ SettingsPerlCommand="$PerlCmd"
+ SettingsDllWrapCommand="/bin/false"
+ SettingsWindresCommand="/bin/false"
+ SettingsTouchCommand='touch'
fi
AC_SUBST(SettingsCCompilerCommand)
AC_SUBST(SettingsCCompilerFlags)
+AC_SUBST(SettingsPerlCommand)
+AC_SUBST(SettingsDllWrapCommand)
+AC_SUBST(SettingsWindresCommand)
+AC_SUBST(SettingsTouchCommand)
dnl ** figure out how to do context diffs
FP_PROG_CONTEXT_DIFF