summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2011-04-28 00:23:28 +0100
committerIan Lynagh <igloo@earth.li>2011-04-28 00:23:28 +0100
commit429c76234f1c3c45e35891aae3bcc78e235cbe25 (patch)
treee57b00d615bf15c49070efcae1cec792434c877e /configure.ac
parent32f24ddfd9549010dd345733c6f46f67196cacf6 (diff)
downloadhaskell-429c76234f1c3c45e35891aae3bcc78e235cbe25.tar.gz
configure: bootstrapping fix (#5155)
Don't check ghc compiles for the right platform when we're bootstrapping.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 9278126f3d..96950cb6fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -305,12 +305,15 @@ checkOS "$TargetOS"
# Verify that the installed (bootstrap) GHC is capable of generating
# code for the requested build platform.
-if test "$BuildPlatform" != "$bootstrap_target"
+if test "$BootingFromHc" = "NO"
then
- echo "This GHC (${WithGhc}) does not generate code for the build platform"
- echo " GHC target platform : $bootstrap_target"
- echo " Desired build platform : $BuildPlatform"
- exit 1
+ if test "$BuildPlatform" != "$bootstrap_target"
+ then
+ echo "This GHC (${WithGhc}) does not generate code for the build platform"
+ echo " GHC target platform : $bootstrap_target"
+ echo " Desired build platform : $BuildPlatform"
+ exit 1
+ fi
fi
echo "GHC build : $BuildPlatform"