summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2006-08-25 19:36:03 +0000
committerIan Lynagh <igloo@earth.li>2006-08-25 19:36:03 +0000
commitaea7d71f37c69e778047e5c3f19d4c75260d2405 (patch)
tree68dd83fc8d1113b1ba9af311cd057cc75341d942 /configure.ac
parent6b1654fcde8626a1acc618ca9bfd261fa13728c2 (diff)
downloadhaskell-aea7d71f37c69e778047e5c3f19d4c75260d2405.tar.gz
Add mipsel case to configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index da482a0d3f..042f33ba8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -387,6 +387,15 @@ mips-*-linux*)
HostVendor_CPP='unknown'
HostOS_CPP='linux'
;;
+mipsel-*-linux*)
+ HostPlatform=mipsel-unknown-linux # hack again
+ TargetPlatform=mipsel-unknown-linux
+ BuildPlatform=mipsel-unknown-linux
+ HostPlatform_CPP='mipsel_unknown_linux'
+ HostArch_CPP='mipsel'
+ HostVendor_CPP='unknown'
+ HostOS_CPP='linux'
+ ;;
mips-dec-ultrix*)
HostPlatform_CPP='mips_dec_ultrix'
HostArch_CPP='mipsel' # NB a little different