summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Sandberg Eriksson <adam@sandbergericsson.se>2018-12-31 00:42:35 +0100
committerBen Gamari <ben@well-typed.com>2019-01-01 12:02:59 -0500
commit7fcc07c89fcc7f17c4a54e23bba884c8cc0982c3 (patch)
tree890451d7fb5d3b5f8f9be53549928106a11bb688 /configure.ac
parent374e44704b64afafc1179127e6c9c5bf1715ef39 (diff)
downloadhaskell-7fcc07c89fcc7f17c4a54e23bba884c8cc0982c3.tar.gz
configure: introduce HAPPY and ALEX vars and deprecate --with-ghc in favour of the GHC var
Also updates the windows gitlab ci to use the new configure variables.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 874a128bdf..b75220d54a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,14 +87,12 @@ dnl use either is considered a Feature.
dnl ** What command to use to compile compiler sources ?
dnl --------------------------------------------------------------
+AC_ARG_VAR(GHC,[Use as the path to GHC [default=autodetect]])
+AC_PATH_PROG([GHC], [ghc])
AC_ARG_WITH([ghc],
-[AC_HELP_STRING([--with-ghc=ARG],
- [Use ARG as the path to GHC [default=autodetect]])],
- [WithGhc="$withval"],
- [if test "$GHC" = ""; then
- AC_PATH_PROG([GHC], [ghc])
- fi
- WithGhc="$GHC"])
+ AS_HELP_STRING([--with-ghc=ARG], [Use ARG as the path to ghc (obsolete, use GHC=ARG instead) [default=autodetect]]),
+ AC_MSG_ERROR([--with-ghc=$withval is obsolete (use './configure GHC=$withval' or 'GHC=$withval ./configure' instead)]))
+AC_SUBST(WithGhc,$GHC)
dnl ** Tell the make system which OS we are using
dnl $OSTYPE is set by the operating system to "msys" or "cygwin" or something
@@ -867,9 +865,13 @@ dnl ** check for ghc-pkg command
FP_PROG_GHC_PKG
dnl ** check for installed happy binary + version
+
+AC_ARG_VAR(HAPPY,[Use as the path to happy [default=autodetect]])
FPTOOLS_HAPPY
dnl ** check for installed alex binary + version
+
+AC_ARG_VAR(ALEX,[Use as the path to alex [default=autodetect]])
FPTOOLS_ALEX
dnl --------------------------------------------------