summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTakenobu Tani <takenobu.hs@gmail.com>2019-11-06 21:06:58 +0900
committerMarge Bot <ben+marge-bot@smart-cactus.org>2019-11-07 08:42:15 -0500
commita956663291435cbcb3ad7bc5db01597e8604063a (patch)
treedf3bf699f04ccbf319b32f4d7e7350a0f27313ff /configure.ac
parentfa0b1b4b38492d6c640704874de91298a4567613 (diff)
downloadhaskell-a956663291435cbcb3ad7bc5db01597e8604063a.tar.gz
configure: Modify ERROR to WARN for sphinx's python check
If sphinx's python version check failed, many people prefer to build without documents instead of stopping on the error. So this commit fixes the following: * Modify AC_MSG_ERROR to AC_MSG_WARN * Add clearing of SPHINXBUILD variable when check fails See also !2016.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2711840ddb..00fb9a5568 100644
--- a/configure.ac
+++ b/configure.ac
@@ -842,7 +842,8 @@ FP_COMPARE_VERSIONS([$fp_cv_sphinx_version],-lt,1.0.0,
[AC_MSG_WARN([Sphinx version 1.0.0 or later is required to build documentation]); SPHINXBUILD=;])
if test -n "$SPHINXBUILD"; then
if "$SPHINXBUILD" -b text utils/check-sphinx utils/check-sphinx/dist > /dev/null 2>&1; then true; else
- AC_MSG_ERROR([Sphinx for python3 is required to build documentation.])
+ AC_MSG_WARN([Sphinx for python3 is required to build documentation.])
+ SPHINXBUILD=;
fi
fi