summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2008-07-03 13:24:37 +0000
committerIan Lynagh <igloo@earth.li>2008-07-03 13:24:37 +0000
commitcf071813ab8d7edd8ca92a2191812a96e9cb20f0 (patch)
tree3989cd014738e4ac47a9a683b516597ed13aee45 /configure.ac
parenteceaec37643c089f03677faa86481b03c0fd784f (diff)
downloadhaskell-cf071813ab8d7edd8ca92a2191812a96e9cb20f0.tar.gz
Tweak the configure script Windows-specific bits
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 18 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 31e827b21f..f22ffbe571 100644
--- a/configure.ac
+++ b/configure.ac
@@ -683,13 +683,12 @@ AC_ARG_WITH(gcc,
[AC_HELP_STRING([--with-gcc=ARG],
[Use ARG as the path to GCC [default=autodetect]])],
[WhatGccIsCalled="$withval"
- if test "x$HostPlatform" = "xi386-unknown-mingw32"
- then
- if test "${OSTYPE}" != "msys"
- then
- # Canonicalise to <drive>:/path/to/gcc
- withval=`cygpath -m ${withval}`
- fi
+ if test "x$HostPlatform" = "xi386-unknown-mingw32" && \
+ test "${OSTYPE}" != "msys" && \
+ test "${withval}" != ""
+ then
+ # Canonicalise to <drive>:/path/to/gcc
+ withval=`cygpath -m ${withval}`
fi;
CC="$withval"
export CC
@@ -703,13 +702,12 @@ dnl --------------------------------------------------------------
AC_ARG_WITH(ld,
[AC_HELP_STRING([--with-ld=ARG],
[Use ARG as the path to LD [default=autodetect]])],
-[if test "x$HostPlatform" = "xi386-unknown-mingw32"
- then
- if test "${OSTYPE}" != "msys"
- then
- # Canonicalise to <drive>:/path/to/ld
- withval=`cygpath -m ${withval}`
- fi
+[if test "x$HostPlatform" = "xi386-unknown-mingw32" && \
+ test "${OSTYPE}" != "msys" && \
+ test "${withval}" != ""
+ then
+ # Canonicalise to <drive>:/path/to/ld
+ withval=`cygpath -m ${withval}`
fi;
LD=$withval
FP_PROG_LD([$LD])
@@ -956,13 +954,12 @@ AC_PATH_PROGS(TarCmd,gtar tar,tar)
AC_PATH_PROG(HSCOLOUR,HsColour)
# HsColour is passed to Cabal, so we need a native path
-if test "x$HostPlatform" = "xi386-unknown-mingw32"
- then
- if test "${OSTYPE}" != "msys"
- then
- # Canonicalise to <drive>:/path/to/gcc
- HSCOLOUR=`cygpath -m ${HSCOLOUR}`
- fi
+if test "x$HostPlatform" = "xi386-unknown-mingw32" && \
+ test "${OSTYPE}" != "msys" && \
+ test "${HSCOLOUR}" != ""
+then
+ # Canonicalise to <drive>:/path/to/gcc
+ HSCOLOUR=`cygpath -m ${HSCOLOUR}`
fi
dnl ** check for DocBook toolchain