summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorManuel M T Chakravarty <chak@cse.unsw.edu.au>2006-08-07 00:05:18 +0000
committerManuel M T Chakravarty <chak@cse.unsw.edu.au>2006-08-07 00:05:18 +0000
commit7caf75c49e6d4b7eb1b88280841bcca9d6a8af00 (patch)
tree252b65a585d36d86cf13384bca9bb620eb20cc99 /configure.ac
parenta27271f99ff254f995a9403fe36e41b9588d1b32 (diff)
downloadhaskell-7caf75c49e6d4b7eb1b88280841bcca9d6a8af00.tar.gz
Configure changes to make testsuite work better on MSys
Fri Jul 28 06:49:35 EDT 2006 simonpj@microsoft.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3b6cc97c2b..7d27a376c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -615,7 +615,12 @@ case $HostPlatform in
hardtop=`cygpath -w ${cyghardtop} | sed -e 's@\\\\@/@g'`
hardtop_plat=`cygpath -w ${cyghardtop} | sed -e 's@\\\\@\\\\\\\\@g'`
else
- hardtop_plat=${hardtop}
+dnl OK, so we're in the MSYS case. hardtop looks like /c/....
+dnl We want to make hardtop_plat into c:/...
+dnl Stop using [] for quotes temporarily, so we can use [] in the sed regexp
+changequote(, )dnl
+ hardtop_plat=`echo ${hardtop} | sed -e 's@^/\\([a-zA-Z]\\)/@\\1:/@g'`
+changequote([, ])dnl
fi
;;
*)