summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2018-06-17 09:54:18 -0400
committerBen Gamari <ben@smart-cactus.org>2018-06-17 10:00:57 -0400
commitd1c7239c037e267873658160b5c290f08f0d6502 (patch)
treefbc77be1a2d36dc73442737ed815b4c7a4a086bb /configure.ac
parent0db05ad9e4d2737e69e640a82f809a5cf8e253ad (diff)
downloadhaskell-d1c7239c037e267873658160b5c290f08f0d6502.tar.gz
configure: Fail when bootstrapping with GHC 8.2.1
See #15281
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2e6e64481c..09889abeaf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,6 +132,11 @@ AC_ARG_VAR(CC_STAGE0, [C compiler command (bootstrap)])
if test "$WithGhc" != ""; then
FPTOOLS_GHC_VERSION([GhcVersion], [GhcMajVersion], [GhcMinVersion], [GhcPatchLevel])dnl
+ # See #15281
+ if test "$GhcMajVersion" = "8" && test "$GhcMinVersion" = "2" && test "$GhcPatchLevel" = "1"; then
+ AC_MSG_ERROR([GHC 8.2.1 is known to be buggy and cannot bootstrap this GHC release (See Trac 15281); please use GHC 8.2.2 or later.])
+ fi
+
if test "$GhcMajVersion" = "unknown" || test "$GhcMinVersion" = "unknown"; then
AC_MSG_ERROR([Cannot determine the version of $WithGhc. Is it really GHC?])
fi