summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2007-03-13 22:05:45 +0000
committerIan Lynagh <igloo@earth.li>2007-03-13 22:05:45 +0000
commit9b582344cdc8d906d923573ae3b20a3f837f3fdf (patch)
treef1c4fb0b2cb2ee4fa5855d74706b8057ad17b8fb /configure.ac
parent8b7e4e09174a407fb4e9f6e8f2e105c9d272b214 (diff)
downloadhaskell-9b582344cdc8d906d923573ae3b20a3f837f3fdf.tar.gz
Fix the way configure sets the ghc_ge_* variables
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d4335229e1..6067f3c989 100644
--- a/configure.ac
+++ b/configure.ac
@@ -715,15 +715,17 @@ if test "$WithGhc" != ""; then
AC_SUBST(GhcMajVersion)dnl
AC_SUBST(GhcMinVersion)dnl
AC_SUBST(GhcPatchLevel)dnl
- ghc_ge_504=`if test $(GhcCanonVersion) -ge 504; then echo YES; else echo NO; fi`
+ GhcMinVersion2=`echo "$GhcMinVersion" | sed 's/^\\(.\\)$/0\\1/'`
+ GhcCanonVersion="$GhcMajVersion$GhcMinVersion2"
+ if test $GhcCanonVersion -ge 504; then ghc_ge_504=YES; else ghc_ge_504=NO; fi
+ if test $GhcCanonVersion -ge 601; then ghc_ge_601=YES; else ghc_ge_601=NO; fi
+ if test $GhcCanonVersion -ge 602; then ghc_ge_602=YES; else ghc_ge_602=NO; fi
+ if test $GhcCanonVersion -ge 603; then ghc_ge_603=YES; else ghc_ge_603=NO; fi
+ if test $GhcCanonVersion -ge 605; then ghc_ge_605=YES; else ghc_ge_605=NO; fi
AC_SUBST(ghc_ge_504)dnl
- ghc_ge_601=`if test $(GhcCanonVersion) -ge 601; then echo YES; else echo NO; fi`
AC_SUBST(ghc_ge_601)dnl
- ghc_ge_602=`if test $(GhcCanonVersion) -ge 602; then echo YES; else echo NO; fi`
AC_SUBST(ghc_ge_602)dnl
- ghc_ge_603=`if test $(GhcCanonVersion) -ge 603; then echo YES; else echo NO; fi`
AC_SUBST(ghc_ge_603)dnl
- ghc_ge_605=`if test $(GhcCanonVersion) -ge 605; then echo YES; else echo NO; fi`
AC_SUBST(ghc_ge_605)dnl
fi