summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2015-04-08 15:11:38 +1000
committerErik de Castro Lopo <erikd@mega-nerd.com>2015-04-11 06:45:07 +1000
commit485dba86d2519cc4855e01db279e127d0221f88a (patch)
treed9dd0fbf24a46c2a719a6c22334b0e68bda8b012 /configure.ac
parent9d16808e1b6dd2fb7ab3eb5712d9842e77d57631 (diff)
downloadhaskell-485dba86d2519cc4855e01db279e127d0221f88a.tar.gz
configure : LLVM and LD detections improvements (#10234).
* distrib/configure.ac.in : Detect correct version of LLVM tools as was done for the top level configure.ac in 42448e3757. * aclocal.m4 : Add a FIND_LD macro that can be used in both configure scripts. * Use new FIND_LD macro in both configure scripts. Signed-off-by: Erik de Castro Lopo <erikd@mega-nerd.com> Test Plan: validate on amd64-linux and armhf-linux. Reviewers: rwbarton, austin Subscribers: thomie Differential Revision: https://phabricator.haskell.org/D828 GHC Trac Issues: #10234
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 5 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index fc6b3c217e..d5d9ab3032 100644
--- a/configure.ac
+++ b/configure.ac
@@ -437,19 +437,7 @@ AC_SUBST([HaskellCPPArgs])
dnl ** Which ld to use?
dnl --------------------------------------------------------------
-FP_ARG_WITH_PATH_GNU_PROG([LD], [ld], [ld])
-case $target in
-arm*linux*)
- # Arm requires use of the binutils ld.gold linker.
- # This case should catch at least arm-unknown-linux-gnueabihf and
- # arm-linux-androideabi.
- FP_ARG_WITH_PATH_GNU_PROG([LD_GOLD], [ld.gold], [ld.gold])
- LdCmd="$LD_GOLD"
- ;;
-*)
- LdCmd="$LD"
- ;;
-esac
+FIND_LD([LdCmd])
AC_SUBST([LdCmd])
dnl ** Which nm to use?
@@ -487,17 +475,18 @@ esac
# tools we are looking for. In the past, GHC supported a number of
# versions of LLVM simultaneously, but that stopped working around
# 3.5/3.6 release of LLVM.
-llvm_version=3.6
+LlvmVersion=3.6
+AC_SUBST([LlvmVersion])
dnl ** Which LLVM llc to use?
dnl --------------------------------------------------------------
-FIND_LLVM_PROG([LLC], [llc], [llc], [$llvm_version])
+FIND_LLVM_PROG([LLC], [llc], [llc], [$LlvmVersion])
LlcCmd="$LLC"
AC_SUBST([LlcCmd])
dnl ** Which LLVM opt to use?
dnl --------------------------------------------------------------
-FIND_LLVM_PROG([OPT], [opt], [opt], [$llvm_version])
+FIND_LLVM_PROG([OPT], [opt], [opt], [$LlvmVersion])
OptCmd="$OPT"
AC_SUBST([OptCmd])