summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHerbert Valerio Riedel <hvr@gnu.org>2015-12-27 09:03:44 +0100
committerHerbert Valerio Riedel <hvr@gnu.org>2015-12-28 10:23:37 +0100
commit01299ca83996710ec1572c952917157b1c2d139e (patch)
tree6840cf59bcc1b45baea77dfd33c3331336489c70 /configure.ac
parent0054bcd42260d248e391ed01d6b3da4fefdad45c (diff)
downloadhaskell-01299ca83996710ec1572c952917157b1c2d139e.tar.gz
Synchronise ghci-package version with ghc-package
In order to simplify the task, the version munging logic has been radically simplified: Previously, in cases where the version contained dates as version components, the build-system would munge the version of the stage1 ghc package before registering the `ghc` package. However, this hack was already questionable at the time of its introduction (c.f. 7b45c46cbabe1288ea87bd9b94c57e010ed17e60). Simplifying the build-systems by avoiding such hacks may also help the shaking-up-ghc effort. So now we simply munge directly via the `.cabal` files, which gives a simpler picture, as now every stage is munged the same. Munging is only active when the first patch-level version component is a date. So stable snapshots and release candidates are unaffacted (as those have the date in the second patch-level version component) Reviewers: simonmar, bgamari, austin, thomie, ezyang Reviewed By: bgamari, thomie, ezyang Differential Revision: https://phabricator.haskell.org/D1673
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 69cdd2b7e4..f5d624db26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1103,7 +1103,7 @@ if test -e shake-build/cfg/system.config.in; then
AC_CONFIG_FILES([shake-build/cfg/system.config])
fi
-AC_CONFIG_FILES([mk/config.mk mk/install.mk mk/project.mk compiler/ghc.cabal ghc/ghc-bin.cabal utils/runghc/runghc.cabal settings docs/users_guide/ghc_config.py docs/index.html libraries/prologue.txt distrib/configure.ac])
+AC_CONFIG_FILES([mk/config.mk mk/install.mk mk/project.mk compiler/ghc.cabal ghc/ghc-bin.cabal utils/runghc/runghc.cabal libraries/ghc-boot/ghc-boot.cabal libraries/ghci/ghci.cabal settings docs/users_guide/ghc_config.py docs/index.html libraries/prologue.txt distrib/configure.ac])
AC_OUTPUT
# We got caught by