summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHerbert Valerio Riedel <hvr@gnu.org>2015-12-31 13:47:43 +0100
committerHerbert Valerio Riedel <hvr@gnu.org>2015-12-31 22:35:50 +0100
commit2f923ce2ab8bad6d01645c735c81bbf1b9ff1e05 (patch)
tree8a21936336868ae1bdaf5b10eb8a1d58480a4727 /configure.ac
parent0d20737860c29169d89c1d5ea728f3848cc28564 (diff)
downloadhaskell-2f923ce2ab8bad6d01645c735c81bbf1b9ff1e05.tar.gz
Drop pre-AMP compatibility CPP conditionals
Since GHC 8.1/8.2 only needs to be bootstrap-able by GHC 7.10 and GHC 8.0 (and GHC 8.2), we can now finally drop all that pre-AMP compatibility CPP-mess for good! Reviewers: austin, goldfire, bgamari Subscribers: goldfire, thomie, erikd Differential Revision: https://phabricator.haskell.org/D1724
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0ff4769742..669dce3fee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,8 +135,8 @@ if test "$WithGhc" = ""
then
AC_MSG_ERROR([GHC is required.])
fi
-FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[7.8],
- [AC_MSG_ERROR([GHC version 7.8 or later is required to compile GHC.])])
+FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[7.10],
+ [AC_MSG_ERROR([GHC version 7.10 or later is required to compile GHC.])])
if test `expr $GhcMinVersion % 2` = "1"
then