summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2015-10-24 11:53:06 +0200
committerBen Gamari <ben@smart-cactus.org>2015-10-24 12:07:07 +0200
commit798d2e2bc3d4bca4de0b62a2e4483138a2a46568 (patch)
treeb3d16e31897715d85aa21207f53020ce21b72276 /configure.ac
parentec14392bb4974b120a701b20c57f562ad288bfe5 (diff)
downloadhaskell-798d2e2bc3d4bca4de0b62a2e4483138a2a46568.tar.gz
configure.ac: Fix autotool warnings
Test Plan: perl boot and check for warnings Reviewers: niteria, austin, bgamari Reviewed By: bgamari Subscribers: thomie Differential Revision: https://phabricator.haskell.org/D1364
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index dabcbcd78a..2f1656d400 100644
--- a/configure.ac
+++ b/configure.ac
@@ -772,15 +772,15 @@ fi
dnl ** check for Sphinx toolchain
AC_PATH_PROG(SPHINXBUILD,sphinx-build)
-AC_CACHE_CHECK([for version of sphinx-build], sphinx_version,
+AC_CACHE_CHECK([for version of sphinx-build], fp_cv_sphinx_version,
changequote(, )dnl
[if test -n "$SPHINXBUILD"; then
- sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed 's/Sphinx\( (sphinx-build)\)\? v\?\([0-9]\.[0-9]\.[0-9]\)/\2/' | head -n1`;
+ fp_cv_sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed 's/Sphinx\( (sphinx-build)\)\? v\?\([0-9]\.[0-9]\.[0-9]\)/\2/' | head -n1`;
fi;
changequote([, ])dnl
])
-FP_COMPARE_VERSIONS([$sphinx_version],-lt,1.0.0,
- [AC_MSG_ERROR([Sphinx version 1.0.0 or later is required to build documentation]); SPHINXBUILD=;])
+FP_COMPARE_VERSIONS([$fp_cv_sphinx_version],-lt,1.0.0,
+ [AC_MSG_WARN([Sphinx version 1.0.0 or later is required to build documentation]); SPHINXBUILD=;])
dnl ** check for xelatex
AC_PATH_PROG(XELATEX,xelatex)