summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <bgamari.foss@gmail.com>2015-12-17 12:14:17 +0100
committerBen Gamari <ben@smart-cactus.org>2015-12-17 12:54:31 +0100
commit86ad116fd73824776a6addd7b068db4358093bee (patch)
treed340000d647c61f245eff4ff6cbe621e40678174 /configure.ac
parent0cc4aad36f91570b1b489e3d239256d1c781daac (diff)
downloadhaskell-86ad116fd73824776a6addd7b068db4358093bee.tar.gz
Add Shake configuration to configure.ac
The Shake build system requires that this file be generated by autoconf. Generate it if we find a shake tree. Reviewers: austin, hvr Reviewed By: hvr Subscribers: thomie, erikd Differential Revision: https://phabricator.haskell.org/D1638
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c8708ae7db..0f335a48a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1098,6 +1098,9 @@ if grep ' ' compiler/ghc.cabal.in 2>&1 >/dev/null; then
AC_MSG_ERROR([compiler/ghc.cabal.in contains tab characters; please remove them])
fi
+if test -e shake/cfg/system.config.in; then
+ AC_CONFIG_FILES([shake/cfg/system.config])
+fi
AC_CONFIG_FILES([mk/config.mk mk/install.mk mk/project.mk compiler/ghc.cabal ghc/ghc-bin.cabal utils/runghc/runghc.cabal settings docs/users_guide/ghc_config.py docs/index.html libraries/prologue.txt distrib/configure.ac])
AC_OUTPUT