summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Miedema <thomasmiedema@gmail.com>2016-01-08 20:59:28 +0100
committerThomas Miedema <thomasmiedema@gmail.com>2016-01-08 23:46:36 +0100
commitf7b45c31f07daa4c3dca39f6ccc1a52c86900b7c (patch)
tree208a16b18369b65ee6f9725cf69ace50b5777a82 /configure.ac
parent2bd05b889f39e5ddf43a723b817b92fc6f4fc6d4 (diff)
downloadhaskell-f7b45c31f07daa4c3dca39f6ccc1a52c86900b7c.tar.gz
Build system: fix `pwd` issues on Windows
Some parts of the build system require that paths are what msys2 calls "mixed style": * forwards slashes * absolute paths starting with a drive letter followed by a colon (e.g. "C:") The removal of ghc-pwd in 4c56ad3 changed $(TOP) from mixed style to unix style, resulting in a broken Windows build for some. Differential Revision: https://phabricator.haskell.org/D1752
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ab82bb0bfe..e9bdeec0fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,8 +26,6 @@ AC_INIT([The Glorious Glasgow Haskell Compilation System], [8.1], [glasgow-haske
# checkout), then we ship a file 'VERSION' containing the full version
# when the source distribution was created.
-FP_FIND_ROOT
-
if test ! -f mk/config.h.in; then
echo "mk/config.h.in doesn't exist: perhaps you haven't run 'perl boot'?"
exit 1
@@ -260,6 +258,9 @@ AC_ARG_WITH(hc,
)
AC_SUBST(WithHc)
+# Requires FPTOOLS_SET_PLATFORM_VARS to be run first.
+FP_FIND_ROOT
+
fail() {
echo >&2
echo "$1" >&2