summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTamar Christina <tamar@zhox.com>2017-09-25 19:12:35 +0100
committerTamar Christina <tamar@zhox.com>2017-09-26 00:19:01 +0100
commitc839c57ed372203b05407b2042d00c188af75310 (patch)
tree229791d8cb9df78050acc1f95585bc1107cdcf6b /configure.ac
parent2b2595e03d328f8c49afe55f765635c03dc81865 (diff)
downloadhaskell-c839c57ed372203b05407b2042d00c188af75310.tar.gz
Fix the searching of target AR tool
Summary: Ar was being checked twice prior to D3883 where I removed one of the checks because the converted path was being overridden after the check because of the second check for Ar. However the one in configure.ac was a target check so I'm changing the path check to a target check now. Test Plan: ./configure Reviewers: angerman, austin, hvr, bgamari Reviewed By: bgamari Subscribers: rwbarton, thomie, erikd GHC Trac Issues: #14274 Differential Revision: https://phabricator.haskell.org/D4020
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 98fffe1bae..5eae83db96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -609,9 +609,7 @@ dnl ** which libtool to use?
dnl --------------------------------------------------------------
# The host normalization on Windows breaks autoconf, it no longer
# thinks that target == host so it never checks the unqualified
-# tools for Windows. I don't know why we do this whole normalization thing
-# as it just breaks everything.. but for now, just check the unqualified one
-# if on Windows.
+# tools for Windows. See #14274.
if test "$HostOS" = "mingw32"
then
AC_PATH_PROG([LIBTOOL],[libtool])