summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2007-04-06 15:18:22 +0000
committerIan Lynagh <igloo@earth.li>2007-04-06 15:18:22 +0000
commit5c789e424c1461c1dadfd38c44fcb9e8f38bf755 (patch)
tree6467bad90d99d7400c460e01bde1d973d05893cf /configure.ac
parentde777ba42eb12b6a20e548a959b23b60179d9b57 (diff)
downloadhaskell-5c789e424c1461c1dadfd38c44fcb9e8f38bf755.tar.gz
Fixes for building the libraries with cabal on Windows
* configure can be told where ld is * make an hsc2hs-inplace.bat * tell Setup configure about foo.bar rather than foo on Windows * tell Setup configure to pass a --with-cc=$(CC) argument to ./configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6067f3c989..dce5a07d22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -756,6 +756,25 @@ AC_ARG_WITH(gcc,
)
AC_SUBST(WhatGccIsCalled)
+dnl ** Which ld to use?
+dnl --------------------------------------------------------------
+AC_ARG_WITH(ld,
+[AC_HELP_STRING([--with-ld=ARG],
+ [Use ARG as the path to LD [default=autodetect]])],
+[if test "x$HostPlatform" = "xi386-unknown-mingw32"
+ then
+ if test "${OSTYPE}" != "msys"
+ then
+ # Canonicalise to <drive>:/path/to/ld
+ withval=`cygpath -w ${withval} | sed -e 's@\\\\@/@g' `
+ fi
+ fi;
+ LD=$withval
+ FP_PROG_LD([$LD])
+ ],
+ [FP_PROG_LD()]
+)
+
dnl ** Booting from .hc files?
dnl --------------------------------------------------------------
AC_ARG_ENABLE(hc-boot,