summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsimonmar <unknown>2005-01-10 11:45:24 +0000
committersimonmar <unknown>2005-01-10 11:45:24 +0000
commitf13895fc3b7a38c909ee0d2d7c1de24381858024 (patch)
tree818a7fb92c8ec21350ec5644ea5dfb75efdfec2b /configure.ac
parentd27af86534166ba4eea5d23768a1d01c431977f1 (diff)
downloadhaskell-f13895fc3b7a38c909ee0d2d7c1de24381858024.tar.gz
[project @ 2005-01-10 11:45:19 by simonmar]
Work around problems caused by limit on the length of the command line in ld, which shows up when building OpenGL on Windows with SplitObjs=YES. We now pass the names of the input files to ld via a linker script. This is (probably) only supported by GNU ld, so we now have to detect GNU ld in the configure script (yawn) and back off to the old method if we don't have it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e2d7536b9f..44353a1993 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1257,6 +1257,7 @@ case $HostOS_CPP in
esac
AC_SUBST(LdCmd)
FPTOOLS_LD_X
+FPTOOLS_GNU_LD
AC_CONFIG_FILES([mk/config.mk])
AC_CONFIG_COMMANDS([mk/stamp-h],[echo timestamp > mk/stamp-h])